App Degraded Performance
Incident Report for Plum Fintech
Resolved
This incident has been resolved and all operations have gone back to normal now.

Thank you for your patience!
Posted Nov 26, 2021 - 11:58 GMT
Monitoring
The issue has been identified and fixes applied.

The App usage is getting back to normal. We are still monitoring to make sure that this is resolved.
Posted Nov 26, 2021 - 11:42 GMT
Update
We are continuing to investigate this issue.
Posted Nov 26, 2021 - 11:16 GMT
Investigating
We are experiencing a connection issue with the App which translates into degraded performance. It may be preventing you from logging in or taking some actions within the app.

We are working to restore the full App accessibilities.

Rest assured that your money is always safe in the meantime!

We're really sorry for the inconvenience!
Posted Nov 26, 2021 - 11:14 GMT
This incident affected: Plum application.