US Stock Screens not loading

Incident Report for Plum Fintech

Resolved

This incident is now resolved.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 23, 2024 - 16:34 BST

Monitoring

A fix was implemented and we are monitoring the results.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 23, 2024 - 10:50 BST

Investigating

We're aware that customers are currently not able to open individual stock screens.

We're working on resolving this issue as quickly as possible.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 23, 2024 - 10:43 BST
This incident affected: 📈 Investments.