Issue with sending emails to microsoft emails
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 11:01 GMT
Investigating
We are currently trying to resolve an issue affecting our ability to send login and signup emails through our system.
Customers with microsoft & outlook mail addresses may be unable to receive emails from our systems.
Posted Oct 29, 2020 - 16:06 GMT