Issues Affecting Sign-Up

Incident Report for Plum Fintech

Update

We are continuing to monitor for any further issues.
Posted Apr 20, 2026 - 09:13 BST

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2026 - 09:15 BST

Monitoring

We are currently investigating an issue impacting a small subset of users during the sign-up process.

Our team is actively working to identify the root cause and implement a resolution as quickly as possible.

We appreciate your patience and understanding while we work on this.
Posted Apr 16, 2026 - 09:14 BST
This incident affects: Plum application, KYC, and Plum Interest.