Plum Interest (MMF) Transactions Delay

Incident Report for Plum Fintech

Resolved

This incident has been resolved and all transactions have been settled. We're sorry for any inconvenience caused.
Posted Oct 30, 2025 - 08:06 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 10:07 GMT

Investigating

We're aware that some customers are experiencing delays in the settlement of their Plum Interest (MMF) transactions.

Our team is working on identifying and resolving the issue as soon as possible.

We're sorry for any inconvenience caused and appreciate your patience.
Posted Oct 29, 2025 - 08:11 GMT
This incident affected: Plum Interest.