Customer Support might not be reachable

Incident Report for Plum Fintech

Resolved

Our customer support platform, Intercom, has resolved the technical issues they were facing.

All communication with our team should be fully operational.

We apologise for any inconvenience this may have caused.
Posted Feb 23, 2024 - 08:21 GMT

Investigating

We’re aware that Intercom, our customer support platform, is having some technical issues this morning.

As a result, some Plum customers may have issues connecting to our customer support agents or may have to wait longer than usual to receive a reply to their message.

We apologise for this and appreciate your patience while the issue is resolved. We are monitoring the situation closely and will keep you updated here.
Posted Feb 22, 2024 - 10:27 GMT
This incident affected: 💬 Chat, 💬 Chat Webviews, 🤗 Live Support, Messenger, and KYC.