Some EU users are unable to complete transactions
Incident Report for Plum Fintech
Resolved
We can confirm this issue is now resolved and migration to our new e-Money payment provider, Modulr, has been completed.

We deeply apologise for any inconvenience caused by this issue. Our teams worked as quickly as they could to rectify this.

Please know that our priority is and has always been to ensure the safety of your funds.

Our customer support team is here to help and answer any questions or concerns you might have; you will find us at help@withplum.com.
Posted Jul 25, 2023 - 13:56 BST
Update
We can confirm that deposits and withdrawals have now been re-enabled for most of the impacted EU customers, and the migration to our new e-Money payment provider, Modulr, is completing.

We’re working hard to rectify the issue for the remaining customers and ensure all of our services are available again.

Rest assured that your funds are safe. Here at Plum, the security of your money is, and always has been, our top priority,
Please accept our sincerest apologies for any inconvenience caused.
Posted Jul 19, 2023 - 10:07 BST
Update
Mise à jour - En raison de circonstances indépendantes de notre volonté, certains clients de l'UE ne sont pas en mesure de déposer ou de retirer de l'argent via l'application Plum, ou d'effectuer des investissements.

Ce problème est lié à notre établissement actuel de monnaie électronique, UAB PayrNet. Notre équipe est en contact régulier avec eux pour résoudre cet incident. Il s'agit de notre priorité absolue et nous travaillons avec eux en continu pour remédier à cette situation le plus rapidement possible.

Soyez assurés que vos fonds sont en sécurité et stockés sur des comptes désignés à cet effet auprès d'une banque agréée.
Nous vous prions d'accepter nos plus sincères excuses pour la gêne occasionnée.
Posted Jun 30, 2023 - 15:04 BST
Update
Due to circumstances beyond our control, some EU customers are not able to deposit or withdraw money via the Plum app, or purchase investments.

This issue relates to our current payment/E-money provider, UAB PayrNet. Our team is in regular contact with them to resolve this. It's our top priority and we’re working with them to rectify this issue as quickly as possible.

Please be assured that your funds are safe and stored in properly designated accounts at a licensed bank.

Please accept our sincerest apologies for any inconvenience caused.
Posted Jun 29, 2023 - 10:50 BST
Update
We're aware of an issue that is impacting some EU customers, which means they are currently not able to deposit or withdraw money via the Plum app, or purchase investments.

We're working on resolving this as quickly as possible. This is our top priority and we'll let you know as soon as it is rectified.

Your funds remain safe with Plum. Please accept our sincerest apologies for any inconvenience caused.
Posted Jun 27, 2023 - 11:15 BST
Identified
We're aware of an issue that is impacting some EU customers, which means they are currently not able to deposit or withdraw money via the Plum app, or purchase investments.

We're working on resolving this as quickly as possible.

Your funds are always safe with Plum. Please accept our apologies for any inconvenience caused
Posted Jun 22, 2023 - 17:44 BST
This incident affected: ➡️ Deposits, ⬅️ Withdrawals, 📈 Investments, and 💳 Plum Card.