App Connectivity Issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 26, 2023 - 08:07 BST
Monitoring
The issue has been identified and a fix has been applied. Plum should be working as normal for all customers.

It was a systemic issue that was quickly fixed from Plum’s side. We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologise for the inconvenience caused and to reassure you that the security of your money was never compromised.

If you are still facing any issues, do not hesitate to contact our customer support team.
Posted Oct 23, 2023 - 14:19 BST
Identified
We are experiencing some connectivity issues with the app which may be preventing you from logging in or taking some actions within the app. It may also prevent the App from retrieving your profile information such as transactions list, pockets & funds balance, etc.

We sincerely apologise and completely understand the inconvenience this may cause but we appreciate your understanding whilst we are working on fully restoring our service.
​

We would also like to assure you that the safety of your money is never compromised in any way.
Posted Oct 23, 2023 - 14:17 BST
This incident affected: Plum application.