Disruption with our Customer Communication Service Provider

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 11:28 BST

Monitoring

A fix has been implemented and our Customer Communication Service Provider is monitoring the results.

We're sorry for any inconvenience this may have caused, and we appreciate your patience.
Posted Oct 21, 2025 - 07:01 BST

Investigating

We’re currently experiencing a disruption with our Customer Communication Service Provider.

This issue is affecting both inbound and outbound messages - Customers are currently unable to send us new messages, and our team cannot view or reply to existing ones.

As soon as the service is restored, all pending messages will be reviewed and responded to as a priority.

We're sorry for any inconvenience this may cause, and we appreciate your patience.
Posted Oct 20, 2025 - 18:44 BST

Monitoring

A fix has been implemented and our Customer Communication Service Provider is monitoring the results.

We're sorry for any inconvenience this may have caused, and we appreciate your patience.
Posted Oct 20, 2025 - 11:59 BST

Investigating

We’re currently experiencing a disruption with our Customer Communication Service Provider.

This issue is affecting both inbound and outbound messages - Customers are currently unable to send us new messages, and our team cannot view or reply to existing ones.

As soon as the service is restored, all pending messages will be reviewed and responded to as a priority.

We're sorry for any inconvenience this may cause, and we appreciate your patience.
Posted Oct 20, 2025 - 08:46 BST
This incident affected: 💬 Chat and 🤗 Live Support.