Free Access Interest Pockets Withdrawals
Incident Report for Plum Fintech
Resolved
This incident has been resolved. Withdrawals from Free Easy Access Pockets will settle as expected.
Posted Nov 18, 2020 - 10:41 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2020 - 10:40 GMT
Identified
We have identified a delay in withdrawals from Free Easy Access Interest pockets. We are currently working on fixing it.

Withdrawals from Premium Easy Access pockets are not affected.

Thank you so much for your patience!
Posted Nov 18, 2020 - 09:43 GMT
This incident affected: ⬅️ Withdrawals.