Delayed Withdrawals from investments
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 13:29 GMT
Identified
Due to operational issues, sellorders created 19-20 February have been delayed. We do apologise for the inconvenience. The new completion estimate will be reflected on your investments.
Posted Feb 28, 2020 - 11:44 GMT
This incident affected: 📈 Investments.