Pending Withdrawals
Incident Report for Plum Fintech
Resolved
This incident has been resolved. Withdrawal processing speeds are back to normal.

We would like to apologise for any inconvenience caused.
Posted Dec 05, 2023 - 15:20 GMT
Identified
We’re aware that some customers might experience issues with withdrawal requests. Due to an issue affecting our payments provider, the withdrawals are processing at a slower pace than usual.

Rest assured that the issue has been identified by our provider and withdrawals are expected to complete once it is resolved.

We’d like to apologise for any inconvenience caused. We will provide relevant updates as soon as possible.
Posted Dec 05, 2023 - 10:08 GMT
This incident affected: ⬅️ Withdrawals.