HSBC connection issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 09:47 GMT
Update
The issue with HSBC is still ongoing. We will keep you updated.
Posted Jan 22, 2020 - 13:51 GMT
Update
We have been advised by HSBC that they have validated the root cause of the current issue. They have advised that a fix will be deployed prior to close of business today. We will keep you updated if anything changes.
Posted Jan 21, 2020 - 12:02 GMT
Identified
HSBC is currently experiencing technical issues. This means that we are having issues gathering data on our end. If you are linked to HSBC your account may not refresh or save. If you are trying to link to HSBC you may experience issues.

It is currently being fixed. It should be sorted in the next few days.

Bear in mind you can still manually deposit/withdraw your funds if you wish.
Posted Jan 20, 2020 - 16:51 GMT
This incident affected: 🏦 Bank Connections.