App Data Loading

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 10:06 GMT

Identified

We're aware that some users may be experiencing loading issues and slower performance with their app.

This is being worked on by our Tech team with the highest priority.

We would like to apologise for the inconvenience this may have caused.
Posted Feb 10, 2025 - 10:25 GMT
This incident affected: Plum application.