Direct Debit Deposits - Settlement Delay
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Jan 05, 2024 - 11:11 GMT
Identified
The issue has now been fixed. Customers who have experienced a delay in their deposits should see them settle later today.

We apologise for any inconvenience. If you have any concerns or would like more details on the status of your deposit, please contact our support team.
Posted Jan 04, 2024 - 09:52 GMT
Investigating
We are aware that some customers might be experiencing a delay in the settlement of their deposits. This is due to a technical issue which we are working on fixing as soon as possible.

We'd like to reassure customers that deposits will be successfully completed, but at a slower pace than usual while this issue is being fixed.

We'd like to apologize for any inconvenience caused. Please be assured that your money is always safe with Plum.
Posted Jan 04, 2024 - 07:54 GMT
This incident affected: ➡️ Deposits.