Bank linking connectivity issue

Incident Report for Plum Fintech

Resolved

This incident has been resolved.

A fix has been deployed and our customers are now able to link again.

Shall you need anything, please do not hesitate to reach out.
Posted Sep 12, 2022 - 08:22 BST

Identified

We are aware that some customers might experience connectivity issue which may prevent them to link their bank account with Plum.

Rest assured that the Tech Team is aware and working on a fix.

In the meantime, the security of your money is never compromised.

We would like to apologise for the inconvenience caused.
Posted Sep 11, 2022 - 09:16 BST
This incident affected: 🏦 Bank Connections.