Interest withdrawals settlement delay
Incident Report for Plum Fintech
Resolved
The issue is now fully resolved. All Interest withdrawals are completed and the money is available in the Primary Pocket.

We would like to apologize for the inconvenience caused. Do not hesitate to reach out if you have any questions.
Posted Jun 01, 2023 - 09:51 BST
Monitoring
This issue has been resolved. All Interest withdrawals have been processed and we are monitoring the situation.

We would like to apologize for the inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Jun 01, 2023 - 08:38 BST
Identified
Were are aware that some customers may experience a delay in the settlement of their withdrawals from their Interest Pocket.

The issue has been identified. Please rest assured that we’re working as quickly as possible to resolve the issue.

We would like to apologize for the inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted May 31, 2023 - 09:47 BST
This incident affected: ⬅️ Withdrawals.