Direct Debit Settlement Delay
Incident Report for Plum Fintech
Resolved
Please note that the incident is now fully resolved and all the Direct Debit deposits estimated to settle on March 25th arrived in the Plum accounts.

We apologize once again for the inconvenience caused.

Shall you need anything else, please do not hesitate to reach out!
Posted Apr 01, 2022 - 09:46 BST
Identified
We are aware that some customers might experience a delay in the settlement of some Direct Debit deposits that were estimated to complete on March 25th. As the issue was identified, our Tech Team is working on it to have the money available in your Plum account as soon as possible.

Please rest assured that your money is always safe in the meantime.

We apologize for the inconvenience caused in the meantime.

Thank you very much for your patience!
Posted Mar 28, 2022 - 11:09 BST
This incident affected: ➡️ Deposits.