Netflix (NFLX) Share Display Discrepancy

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 14:03 GMT

Identified

We're aware that customers holding Netflix Inc. (NFLX) shares are experiencing a discrepancy in how their shares are being displayed.

Please be assured that the underlying value of your shares is not impacted by this issue.

This was caused by an unforeseen technical issue when the 10-for-1 Netflix stock split, which took effect on November 17.

The issue is currently being addressed by our tech team with the highest priority.

We sincerely apologise for any inconvenience this may have caused.
Posted Nov 18, 2025 - 13:48 GMT
This incident affected: 📈 Investments.