App Data Loading
Incident Report for Plum Fintech
Resolved
Please kindly note that the incident is now resolved. The fixed DNS records reached the remaining customers as their ISPs (Internet Service Providers) refreshed them.

If you are still facing any issues, the root cause might be different so we recommend contacting our Support Team that will be happy to help.

We truly apologize for the inconvenience caused and would like to assure you that the security of your money was never compromised.

The necessary measures have already been implemented so this problem does not reoccur in the future.
Posted Mar 23, 2022 - 09:29 GMT
Update
We would like to provide an update in full, in regards to the network issue (DNS) that at the end of last week affected some users' ability to access and use Plum. DNS servers are what translate domain names into IP addresses to lead people to the correct places.

What was the issue?
In essence, our DNS provider had to perform an internal migration to another registrar which included a domain contact update. Typically, such updates are done quickly and we had been told that no action would be necessary on our side. Plum was informed that a verification process had not been completed at our end, resulting in the Internet Corporation for Assigned Names and Numbers (ICANN) suspending the ‘withplum.com’ domain, i.e. a so-called "domain suspension". At that point, occurring at 2022-03-17 09:29 UTC, Plum users gradually started reaching the "domain suspension" page instead of actual Plum endpoints

During the time of the suspension, the entire Plum infrastructure continued to operate normally without compromise or data loss. For users who were not yet reached by the DNS record changes, the Plum application continued to function.

What did we do to fix the issue?
We found out that there were issues reaching our infrastructure at 2022-03-17 10:08 UTC. We immediately figured out that it was a DNS issue and verified the domain at 2022-03-17 10:15 UTC. In order to resolve the issue, we requested a DNS cache flush on all public DNS servers that support that (e.g. Cloudflare & Google). Then we started estimating how many users were affected at that moment and kept monitoring the situation as DNS changes were still propagating.

Is this still ongoing?
Yes. This issue is still affecting a very small percentage of our users. It is ongoing due to certain Internet Service Providers (ISPs) not respecting the Time-To-Live (TTL) property of DNS records. Such providers cache DNS records for an arbitrary amount of time which may be way higher than the TTL of the record. Therefore, our now fixed DNS records can still not reach their users.

We must assure you once again that while access to your account may have been temporarily interrupted, the safety or security of your money was never compromised in any way. We truly apologise for the inconvenience and are working hard to ensure the issue is fully resolved.
Posted Mar 21, 2022 - 14:41 GMT
Update
If you are still waiting for normal access to resume, you may also try connecting to a different network provider. e.g. log in via another wifi network, or switch to mobile data. Once again, we sincerely apologise for any ongoing inconvenience.
Posted Mar 19, 2022 - 17:18 GMT
Update
Whilst we anticipated normal access would be restored Saturday AM (today) please note that some customers may still experience some delays until normal access is again available to everyone.

Once again, we sincerely apologise and completely understand the inconvenience this may cause but we appreciate your understanding whilst we are fully restoring our service.
Posted Mar 19, 2022 - 10:07 GMT
Update
As the fix continues to reach more and more customers, access is gradually & continuously being restored. We anticipate that normal access may not be restored for all our customers until Saturday 19th March AM.

We sincerely apologize for any concern or inconvenience that these ongoing effects may have caused you. We have already introduced measures to ensure that this problem does not reoccur in the future.

Once again, we’d also like to assure you that while access to your account may have been temporarily interrupted, the safety or security of your money was never compromised in any way.
Posted Mar 18, 2022 - 12:31 GMT
Monitoring
Please note that the issue was identified. We are currently affected by a network issue (DNS) that may affect some of our customers' ability to connect or use the App. We have implemented a fix, however, it usually takes 24 hours for the change to propagate to all the affected customers. The service is gradually being restored.

We would like to reassure you that your money remains safe.

Thank you for your patience in the meantime.
Posted Mar 17, 2022 - 17:02 GMT
Investigating
We are currently investigating an issue affecting the App. The home screen, pockets, and balance are not always loading.

Rest assured that your funds are safe in the meantime.

Our Tech Team is working on it as we speak and we will notify you as soon as we get an update.

We apologize for any inconvenience caused in the meantime!

Thank you very much for your patience!
Posted Mar 17, 2022 - 13:11 GMT
This incident affected: Plum application.