Login Issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved
Posted Oct 04, 2024 - 16:41 BST
Update
The issue has been identified and a fix has been applied. Plum should be working as normal for all customers.

We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologize for the inconvenience caused and to reassure you that the security of your money was never compromised.
Posted Oct 04, 2024 - 16:40 BST
Investigating
We're experiencing some connectivity issues that may prevent you from logging in.

We're working hard to restore access to the app as quickly as possible.

We’re sorry for any inconvenience. Rest assured that your money is always safe in the meantime!
Posted Oct 04, 2024 - 16:01 BST
This incident affected: Plum application.