Direct Debit deposits delay
Incident Report for Plum Fintech
Resolved
The incident is now considered resolved. The affected deposits are now completed.

We would like to apologise once again for the inconvenience caused.

If you have any questions or face any issues, please do not hesitate to contact our support team.
Posted Apr 26, 2023 - 07:23 BST
Update
We are aware that some customers are still seeing residual delays in their deposit settlements following yesterday's technical issue.

We would like to apologise for this delay and reassure customers that any outstanding deposits are currently processing.

Please contact our support team directly if you have any concerns about your deposits.
Posted Apr 19, 2023 - 09:43 BST
Monitoring
The issue has now been fixed. Customers who have experienced a delay to their deposits should see them settle today.

Please note that it may take some time for your deposit to be processed today. If you have any concerns, please contact our support team.

We apologise for any inconvenience caused by these delays.
Posted Apr 18, 2023 - 10:30 BST
Identified
We are aware that some customers have experienced a delay in the settlement of their transactions. This is due to a technical issue which we are working on fixing as soon as possible.

We'd like to reassure customers that deposits will successfully complete, but at a slower pace than usual while this issue is being fixed. Please keep an eye on our status page for further updates and contact our support team if you have a question about any transaction in the meantime.

We'd like to apologise for any inconvenience caused by delayed deposits. Please be assured that your money is always safe with Plum.
Posted Apr 18, 2023 - 08:51 BST
This incident affected: ➡️ Deposits.