Several stocks are not being displayed on the discovery page
Incident Report for Plum Fintech
Resolved
This incident has now been resolved and all stocks are being displayed on the discovery page.

We would like to apologise for any inconvenience caused
Posted May 29, 2023 - 10:15 BST
Monitoring
Our services are back to normal and we're continuing to monitor.

We apologise for any inconvenience caused by the issue.
Posted May 27, 2023 - 17:02 BST
Investigating
We are currently investigating this issue.
Posted May 27, 2023 - 09:29 BST
Identified
We’re currently experiencing issues with the display of some stocks on our discovery page.

We’re working as quickly as possible to resolve this. Customers are still able to use the investment feature otherwise as usual.

Please be assured that your money and investments are always safe with Plum.
Posted May 27, 2023 - 09:15 BST
This incident affected: 📈 Investments.