Halifax connection issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 15:50 GMT
Identified
We are currently experiencing connection issues with Halifax accounts. We are liasing with our partner to get this sorted asap.

I am sorry for the inconvenience. Bear in mind you can still manually deposit/withdraw your funds.
Posted Oct 21, 2019 - 09:54 BST
This incident affected: 🏦 Bank Connections.