Delay in Mutual Funds Transactions Settlement

Incident Report for Plum Fintech

Resolved

This incident has been resolved, and all transactions are now settled.

We're sorry for any inconvenience caused.
Posted May 21, 2025 - 18:42 BST

Update

We’re still actively working to resolve the issue affecting the settlement of some Mutual Fund transactions.

We truly appreciate your continued patience and understanding.
Posted May 20, 2025 - 15:16 BST

Identified

We're aware that some customers might be experiencing a delay in completing their Mutual Fund transactions.

The issue has been identified and is being worked on.

We're sorry for any inconvenience caused.
Posted May 13, 2025 - 08:27 BST
This incident affected: 📈 Investments.