Combo depositor did not run
Incident Report for Plum Fintech
Resolved
This issue has now been resolved, so all upcoming automatic deposits will take place as usual next Monday.

If you would like to manually deposit in the meantime, you can do so by tapping ‘Add money’ at the top of your home screen.

We’re really sorry for any inconvenience caused by this!
Posted Jul 10, 2024 - 10:03 BST
Investigating
We're aware that scheduled automated deposit rules did not take place as intended for some customers.

We're currently working on resolving this issue as quickly as possible.

We sincerely apologise for any inconvenience this may have caused and want to reassure you that your money is always safe with Plum.
Posted Jul 08, 2024 - 11:30 BST
This incident affected: Depositors.