Interest Withdrawals settlement delay (April 19th)
Incident Report for Plum Fintech
Resolved
The issue is now fully resolved. All Interest withdrawals are completed and the money is available in the Primary Pocket.

Do not hesitate to reach out if you have any questions.
Posted Apr 22, 2022 - 08:19 BST
Monitoring
Due to an unexpected systemic issue, the finalization of the transactions started later than initially expected which translated into the experienced delay in funds settlement.

As the process has been fully restored, the money is expected to be available by the end of today at the latest in your Plum account.
Posted Apr 20, 2022 - 10:57 BST
Investigating
Were are aware that some customers might experience a delay in the settlement of their withdrawals from their Interest Pocket that were estimated to complete on April 19th.

Please rest assured that we are doing our best to make sure that the transactions complete as soon as possible.

We would like to apologize for the inconvenience caused.
Posted Apr 20, 2022 - 07:39 BST
This incident affected: ⬅️ Withdrawals.